Усовершенствованный редактор правил обмена КД2

Публикация № 398595

Обмен - Обмен через XML

Конвертация данных редактирование правил обмен xml универсальный КД2

144
РПО-2М – мощный редактор правил обмена для КД 2. Позволяет ускорить свою разработку и ознакомление/доработку чужих правил обмена. Превосходство над встроенным редактором достигается за счет удобного функционального интерфейса, применения шаблонизации кода правил, богатого инструментария, упрощающего разработку, и интеграции с Инструментами Разработчика.

Оглавление

  1. Системные требования
  2. Знакомство с интерфейсом
    1. Обзор
    2. Общие настройки
    3. Настройки условного оформления
    4. Прочие настройки
  3. Поиск в конвертации и отборы
  4. История, Избранное и Быстрые ПКО
  5. Шаблоны
  6. Инструменты
  7. Заключение

Системные требования

  1. КД 2.1.8.2 + 8.3. (где разрешили в расширении общие модули)
  2. Инструменты Разработчика //tools.erpstat.ru/public/15126/ (необязательно, но придется немного выковыривать связанное с этой конфигурацией)
  3. Обработка загрузки метаданных конфигурации по СОМ(необязательно) //tools.erpstat.ru/public/76688/
  4. Расширение РПО2 + модификация КД2 для клиент-серверного варианта(для файлового расширения достаточно).

Для клиент-серверного варианта необходимо сделать доработки в модулях форм справочников: Конвертацияи, ПВД, ПКО, ПКС, ПКЗ, Алгоритмы, Запросы, Обработки, Параметры - в событиях ПередЗаписью и ПослеЗаписи:

Процедура ПередЗаписью(Отказ)

    //*********************************

    РПО2_СобытияМодуляОбъекта.ОбработчикПередЗаписьюПосле(ЭтотОбъект);               

КонецПроцедуры

Процедура ПослеЗаписи()  

    //*********************************

    РПО2_СобытияМодуляОбъекта.ОбработчикПриЗаписиПосле(ЭтотОбъект);          

КонецПроцедуры

Знакомство с интерфейсом

Обзор

Удобство начинается с порядка. Порядок на рабочем месте – залог плодотворной и успешной работы. Представленный редактор правил обмена сочетает в себе практичность, эргономичность и эффективный функционал для разработки. Настраиваемый интерфейс, условное оформление, быстрый доступ к глобальным обработчикам, обработчикам правил и т.д. -  эти механизмы призваны ускорить и облегчить работу.

 

 

Общие настройки

Общие настройки интуитивно понятны. Часть из них сохраняется для конвертации, часть для обработки в целом. К примеру, маленькие правила лучше просматривать, когда все объекты в одном дереве: глобальные обработчики, ПВД, алгоритмы и т.д., большие – с разбитием на вкладки; отбор ПКО из дерева ПВД я назначаю, если хочу ознакомиться с правилами или работаю с определенных их куском.

Настройки условного оформления

Настройки УО призваны выделить правила по заданным настройкам либо из макета, либо из файла. Работу флажка «ПоразрядноеСравнение» лучше показать на примере:

- если флаг сброшен, то проверяется условие ‘111’ == ‘101’ Ложь (УО не применяется) 

- если флаг установлен, то проверяется условие ‘111’ & ‘101’ = ‘101’ Истина (УО применяется)

‘111’ – значение полей правила(им присвоены коды)

‘101’ – проверяемые значения УО

Прочие настройки

На вкладке прочее расположены «Описание», соответствующее реквизиту «Описание» в конвертации, и обработчики после сохранения правил. Есть три варианта обработчиков: КОПИЯ, ИСТОРИЯ, АЛГОРИТМ 1С. КОПИЯ – дополнительное копирование файла правил. ИСТОРИЯ – то же самое копирование, но с изменением имени файла приемника, зависящего от выбранной периодичности. АЛГОРИТМ 1С – произвольный код выполняемый в базах Источнике, Приемнике (СОМ соединение) или непосредственно в КДхе.

Поиск в конвертации и отборы

Три режима поиска в конвертации: по имени объекта, по типу объекта(для поиска доступно только дерево ПКОПКСПКЗ), по алгоритмам объекта(есть режим поиска с помощью регулярных выражений). При поиске по алгоритмам существует возможность выбрать алгоритмы для поиска.

Отборы служат для ограничения списка правил только правилами, так или иначе связанными с выбранным правилом, а также для поиска использования выбранного ПКО.

 

История, Избранное и Быстрые ПКО

Список избранного служит для сохранения и последующего использования часто используемых правил. История хранит последние N объектов конвертации, которые были открыты. Панель быстрых ПКО позволяет отбирать ПКС набранных ПКО. Избранное и история восстанавливаются при открытии.

Шаблоны

Шаблоны кода необходимы для быстрого создания обработчиков правил. Список шаблон и результат(демонстрация работы) приведены ниже:

1. Запрос в значение (предполагает наличие в буфере обмена текста запроса)

Исходные данные:

ВЫБРАТЬ
    Объекты.Комментарий КАК Значение
ИЗ
    Справочник.Объекты КАК Объекты
ГДЕ
    Объекты.Ссылка = &Ссылка

Результат:

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
|	Объекты.Комментарий КАК Значение
|ИЗ
|	Справочник.Объекты КАК Объекты
|ГДЕ
|Объекты.Ссылка = &Ссылка";

Запрос.УстановитьПараметр("Ссылка", Источник);

РезультатЗапроса = Запрос.Выполнить();
Выборка = РезультатЗапроса.Выбрать();
Выборка.Следующий();
Значение = Выборка.Значение;

 

2. Запрос в коллекцию  (предполагает наличие в буфере обмена текста запроса)

Исходные данные:

ВЫБРАТЬ
ЗаказКлиентаТовары.Номенклатура,
ЗаказКлиентаТовары.Содержание,
ЗаказКлиентаТовары.Количество,
ЗаказКлиентаТовары.Цена,
ЗаказКлиентаТовары.Сумма,
ЗаказКлиентаТовары.СтавкаНДС,
ЗаказКлиентаТовары.СуммаНДС,
ЗаказКлиентаТовары.СуммаСНДС
ИЗ
Документ.ЗаказКлиента.Товары КАК ЗаказКлиентаТовары
   ВНУТРЕННЕЕ СОЕДИНЕНИЕ Константа.чг_ВидНоменклатурыОС
КАК чг_ВидНоменклатурыОС
     ПО ЗаказКлиентаТовары.Номенклатура.ВидНоменклатуры <>
чг_ВидНоменклатурыОС.Значение
ГДЕ
  ЗаказКлиентаТовары.Ссылка = &Ссылка
  И ЗаказКлиентаТовары.Номенклатура.ТипНоменклатуры
В (ЗНАЧЕНИЕ(Перечисление.ТипыНоменклатуры.Услуга))
      И НЕ ЗаказКлиентаТовары.Отменено

Результат:

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
|ЗаказКлиентаТовары.Номенклатура,
|ЗаказКлиентаТовары.Содержание,
|ЗаказКлиентаТовары.Количество,
|ЗаказКлиентаТовары.Цена,
|ЗаказКлиентаТовары.Сумма,
|ЗаказКлиентаТовары.СтавкаНДС,
|ЗаказКлиентаТовары.СуммаНДС,
|ЗаказКлиентаТовары.СуммаСНДС
|ИЗ
|Документ.ЗаказКлиента.Товары КАК ЗаказКлиентаТовары
|   ВНУТРЕННЕЕ СОЕДИНЕНИЕ Константа.чг_ВидНоменклатурыОС
|КАК чг_ВидНоменклатурыОС
|     ПО ЗаказКлиентаТовары.Номенклатура.ВидНоменклатуры
|<> чг_ВидНоменклатурыОС.Значение
|ГДЕ
|  ЗаказКлиентаТовары.Ссылка = &Ссылка
|  И ЗаказКлиентаТовары.Номенклатура.ТипНоменклатуры В
|(ЗНАЧЕНИЕ(Перечисление.ТипыНоменклатуры.Услуга))
|И НЕ ЗаказКлиентаТовары.Отменено";

Запрос.УстановитьПараметр("Ссылка", Источник);

РезультатЗапроса = Запрос.Выполнить();
КоллекцияОбъектов = РезультатЗапроса.Выгрузить();

 

 

3. Запрос во вх. данные (ИК-КС)*(предполагает наличие в буфере обмена текста запроса)

Исходные данные:

ВЫБРАТЬ ПЕРВЫЕ 1
СоглашенияСКлиентамиЭтапыГрафикаОплаты.Ссылка.ВидЦен КАК ТипЦен,
&ФормаОплаты КАК ФормаОплаты,
&ЭтоДоговорВзаимозачета КАК ЭтоДоговорВзаимозачета
ИЗ
    Справочник.СоглашенияСКлиентами.ЭтапыГрафикаОплаты
КАК СоглашенияСКлиентамиЭтапыГрафикаОплаты
ГДЕ
СоглашенияСКлиентамиЭтапыГрафикаОплаты.Ссылка.Партнер = &Партнер
И СоглашенияСКлиентамиЭтапыГрафикаОплаты.Ссылка.Контрагент = &Контрагент
И СоглашенияСКлиентамиЭтапыГрафикаОплаты.Ссылка.Организация = &Организация
И СоглашенияСКлиентамиЭтапыГрафикаОплаты.Ссылка.Валюта = &ВалютаВзаиморасчетов
И СоглашенияСКлиентамиЭтапыГрафикаОплаты.Ссылка.ФормаОплаты = &ФормаОплаты
И СоглашенияСКлиентамиЭтапыГрафикаОплаты.ВариантОплаты =
ЗНАЧЕНИЕ(Перечисление.ВариантыОплатыКлиентом.КредитПослеОтгрузки)

Результат:

Если ВходящиеДанные = Неопределено Тогда
    ВходящиеДанные = Новый Структура;
КонецЕсли;

ВходящиеДанные.Вставить("ТипЦен");
ВходящиеДанные.Вставить("_Менеджер");

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 1
|СоглашенияСКлиентамиЭтапыГрафикаОплаты.Ссылка.ВидЦен КАК ТипЦен,
|СоглашенияСКлиентамиЭтапыГрафикаОплаты.Ссылка.Менеджер КАК _Менеджер,
|&ЭтоДоговорВзаимозачета КАК ЭтоДоговорВзаимозачета
|ИЗ
|    Справочник.СоглашенияСКлиентами.ЭтапыГрафикаОплаты
|КАК СоглашенияСКлиентамиЭтапыГрафикаОплаты
|ГДЕ
|СоглашенияСКлиентамиЭтапыГрафикаОплаты.Ссылка.Партнер = &Партнер
|И СоглашенияСКлиентамиЭтапыГрафикаОплаты.Ссылка.Контрагент = &Контрагент
|И СоглашенияСКлиентамиЭтапыГрафикаОплаты.Ссылка.Организация = &Организация
|И СоглашенияСКлиентамиЭтапыГрафикаОплаты.Ссылка.Валюта = &ВалютаВзаиморасчетов
|И СоглашенияСКлиентамиЭтапыГрафикаОплаты.Ссылка.ФормаОплаты = &ФормаОплаты
|И СоглашенияСКлиентамиЭтапыГрафикаОплаты.ВариантОплаты =
|ЗНАЧЕНИЕ(Перечисление.ВариантыОплатыКлиентом.КредитПослеОтгрузки)";

Запрос.УстановитьПараметр("Ссылка", Источник);

РезультатЗапроса = Запрос.Выполнить();
Выборка = РезультатЗапроса.Выбрать();
Если Выборка.Следующий() Тогда
    Для каждого Ит Из РезультатЗапроса.Колонки Цикл
        ВходящиеДанные.Вставить(Ит.Имя, Выборка[Ит.Имя]);
    КонецЦикла;
КонецЕсли;

 

4. Запрос во вх. данные (ЗК-КС)*(предполагает наличие в буфере обмена текста запроса)

Исходные данные:

ВЫБРАТЬ ПЕРВЫЕ 1
    ПартнерыКонтактнаяИнформация.Представление КАК Значение,
    ""Этаж"" КАК Ключ
ИЗ
    Справочник.Партнеры.КонтактнаяИнформация КАК ПартнерыКонтактнаяИнформация
ГДЕ
    ПартнерыКонтактнаяИнформация.Ссылка = &Ссылка
    И ПартнерыКонтактнаяИнформация.Тип =
ЗНАЧЕНИЕ(Перечисление.ТипыКонтактнойИнформации.Другое)
    И ПартнерыКонтактнаяИнформация.Вид = &ВидЭтаж

ОБЪЕДИНИТЬ ВСЕ

ВЫБРАТЬ ПЕРВЫЕ 1
    ПартнерыКонтактнаяИнформация.Представление,
    ""Подъезд""
ИЗ
    Справочник.Партнеры.КонтактнаяИнформация КАК
ПартнерыКонтактнаяИнформация
ГДЕ
    ПартнерыКонтактнаяИнформация.Ссылка = &Ссылка
    И ПартнерыКонтактнаяИнформация.Тип =
ЗНАЧЕНИЕ(Перечисление.ТипыКонтактнойИнформации.Другое)
    И ПартнерыКонтактнаяИнформация.Вид = &ВидПодъезд

Результат:

Если ВходящиеДанные = Неопределено Тогда
	ВходящиеДанные = Новый Структура;
КонецЕсли;

ВходящиеДанные.Вставить("Подъезд");
ВходящиеДанные.Вставить("Этаж");

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 1
|	ПартнерыКонтактнаяИнформация.Представление КАК Значение,
|	""Этаж"" КАК Ключ
|ИЗ
|	Справочник.Партнеры.КонтактнаяИнформация КАК ПартнерыКонтактнаяИнформация
|ГДЕ
|	ПартнерыКонтактнаяИнформация.Ссылка = &Ссылка
|	И ПартнерыКонтактнаяИнформация.Тип = ЗНАЧЕНИЕ(Перечисление.ТипыКонтактнойИнформации.Другое)
|	И ПартнерыКонтактнаяИнформация.Вид = &ВидЭтаж
|
|ОБЪЕДИНИТЬ ВСЕ
|
|ВЫБРАТЬ ПЕРВЫЕ 1
|	ПартнерыКонтактнаяИнформация.Представление,
|	""Подъезд""
|ИЗ
|	Справочник.Партнеры.КонтактнаяИнформация КАК ПартнерыКонтактнаяИнформация
|ГДЕ
|	ПартнерыКонтактнаяИнформация.Ссылка = &Ссылка
|	И ПартнерыКонтактнаяИнформация.Тип = ЗНАЧЕНИЕ(Перечисление.ТипыКонтактнойИнформации.Другое)
|И ПартнерыКонтактнаяИнформация.Вид = &ВидПодъезд";

Запрос.УстановитьПараметр("Ссылка", Источник);

РезультатЗапроса = Запрос.Выполнить();
Выборка = РезультатЗапроса.Выбрать();
Если Выборка.Следующий() Тогда
	ВходящиеДанные.Вставить(Выборка.Ключ, Выборка.Значение);
КонецЕсли;

 

5. Инициализация вх. данных*

Исходные данные:

Результат:

ВходящиеДанные = Новый Структура("Услуги, 
|Подразделение, НомерВходящегоДокумента");
ВходящиеДанные.Услуги = Новый ТаблицаЗначений;
ВходящиеДанные.Услуги.Колонки.Добавить("Номенклатура");
ВходящиеДанные.Услуги.Колонки.Добавить("Количество");
ВходящиеДанные.Услуги.Колонки.Добавить("СуммаНДС");
ВходящиеДанные.Услуги.Колонки.Добавить("Сумма");
ВходящиеДанные.Услуги.Колонки.Добавить("СтавкаНДС");
ВходящиеДанные.Услуги.Колонки.Добавить("Цена");
ВходящиеДанные.Услуги.Колонки.Добавить("Содержание");
ВходящиеДанные.Подразделение           = ;
ВходящиеДанные.НомерВходящегоДокумента = ;

 

6. Получение параметров объекта*

Исходные данные:

Результат:

Если ПараметрыОбъекта <> Неопределено Тогда

ПараметрШапки = ПараметрыОбъекта.Получить("ПараметрШапки");
Если ЗначениеЗаполнено(ПараметрШапки) Тогда
    //Обработка параметра ПараметрШапки
КонецЕсли;

ПараметрВыданныеАвансыТабличнаяЧасть =
ПараметрыОбъекта.Получить("ВыданныеАвансыТабличнаяЧасть");
Если ЗначениеЗаполнено(ПараметрВыданныеАвансыТабличнаяЧасть) Тогда
    Для Каждого Ит Из ПараметрВыданныеАвансыТабличнаяЧасть Цикл

          Индекс = ПараметрВыданныеАвансыТабличнаяЧасть.Индекс(Ит);
          СтрокаВыданныеАвансы = Объект.ВыданныеАвансы[Индекс];

          Если ЗначениеЗаполнено(Ит.ПараметрТабличнойЧасти) Тогда
               //Обработка заполнения строки табличной части
          КонецЕсли;

        Если ЗначениеЗаполнено(Ит.ПараметрТабличнойЧасти2) Тогда
               //Обработка заполнения строки табличной части
          КонецЕсли;

    КонецЦикла;
КонецЕсли;

КонецЕсли;

 

7. Произвольный алгоритм ПВД*(предполагает наличие в буфере обмена текста запроса, учитывает параметры и поля итогов)

Исходные данные:

 

Результат:

 

*- параметризованный шаблон, т.е. зависит от выбранного ПКО в дереве ПКОПКСПКЗ

ИК-КС – Имя колонки – ключ структуры вх. данных

ЗК-КС  – Значение колонки – ключ структуры вх. данных

 

Инструменты

Инструмент копирования

Инструмент позволяет копировать выбранные ПКС одного ПКО в другое ПКО с сохранением всех его настроек. Так на рис. ниже оранжевым выделены ПКС для копирования, в которых пользователю предлагается реквизит приемник и, если требуется, источник ввести вручную. Зеленым выделены ПКС, готовые(с найденными реквизитами приемника) для копирования.

 

Инструмент создания структуры объекта

Инструмент служит для создания описания(структуры или таблицы значений) фиктивных (несуществующих на стороне источника) объектов для передачи в приемник.

Инструмент создания соответствия

Создание соответствий необходимо в случаях, когда нет возможности использовать БСПшный регистр СоответствиеОбъектовИнформационныхБаз. Для данного инструмента необходим экселевский файл с колонками поиска и колонками результата. Реализовано два варианта шаблона кода: подмена объекта выгрузки и подмена идентификатора. В первом случае выгружается объект, указанный в таблице соответствий, во втором в файле выгрузки создается ссылка с подмененным идентификатором.

 

Заключение

Основная идея РПО2М - вывести максимум полезной информации в рабочую видимую область и минимизировать количество действий для получения результата. Благодаря реализации этой идеи  редактор упрощает разработку правил обмена.

Видео старой версии, но 70% актуально.

 

UPD 19/03/19

- добавлена проверка обновлений на ЯД

- добавлен новый шаблон "Произвольный алгоритм ПВД"

- расширены возможности инструмента "Мастер создания соответствий"

UPD 20/03/18

- интегрирован с ИР

- добавлены новые шаблоны и инструмент

- расширены возможности поиска

- переработан интерфейс

- исправлены мелкие и не очень ошибки

UPD 13/03/17

- добавлены новые возможности интерфейса

- добавлены обработчики после сохранения правил

- расширены возможности поиска

- оптимизированы алгоритмы поиска и построения дерева ПКО

- добавлены шаблоны текста обработчиков и новый инструмент - получение структуры по объекту.

UPD 01/02/16

- расширен функционал

- переработан интерфейс

- исправлены мелкие ошибки

144

Скачать файлы

Наименование Файл Версия Размер
Редактор правил обмена КД2
.epf 199,67Kb
18.03.19
42
.epf 2.0.0.1 199,67Kb 42 Скачать
Раширение РПО
.cfe 46,08Kb
22.04.18
27
.cfe 2.0.0.0 46,08Kb 27 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. dgolovanov 16.09.15 15:55 Сейчас в теме
2. Cyberhawk 110 16.09.15 17:40 Сейчас в теме
Автор, полагаю, молодец, но в статье не хватает сценариев использования. Поясню: было бы хорошо, если бы было описано, какие конкретно задачи с помощью этого обозревателя можно решить.
PLAstic; for_sale; корум; Brawler; +4 Ответить
3. Lem0n 162 16.09.15 20:22 Сейчас в теме
(2) Cyberhawk, позволяет быстрее ознакомиться с большими правилами обмена, увидеть, управляя глубиной поиска, все ПКО так или иначе связанные с конкретным ПВД или ПКО, т.е. см. рисунок. В итоге в поле твоего зрения попадает только то, с чем ты собираешься работать.
Прикрепленные файлы:
4. Новиков 290 17.09.15 11:50 Сейчас в теме
Опробую в работе. Выглядит интересно!
5. elenika 17.09.15 13:46 Сейчас в теме
На мой взгляд, стоит добавить быстрый переход от ПКС к его ПКО
6. Lem0n 162 18.09.15 11:47 Сейчас в теме
(5) elenika, сделал...дельное замечание, ускоряющее навигацию
7. nkp14108 78 23.09.15 09:10 Сейчас в теме
если б еще сравнение правил!
8. hotey 37 23.09.15 10:14 Сейчас в теме
9. echo77 1075 03.04.17 11:28 Сейчас в теме
10. Lem0n 162 03.04.17 14:10 Сейчас в теме
(9) Начиная с 16.09.15 15:51 (дата создания этой публикации) "хорошая вещь" не актуальна. Сожалею, что ты этого еще не понял/оценил.
11. tomvlad 3725 04.04.17 11:47 Сейчас в теме
(10) Восхитительное самомнение...
madonov; fishca; cleaner_it; for_sale; echo77; +5 Ответить
32. for_sale 681 20.03.19 17:54 Сейчас в теме
(10)
Думаю, вообще вся история человечества разделилась на "до" и "после" 16.09.15 15:51 )))

Ребята, как кто празднует 16.09.15 15:51? Поделитесь в комментариях! Все приносят жертву в храме скромности автора сей публикации или только мы с автором сей публикации?)))
41. Team leader 7 25.03.19 19:48 Сейчас в теме
12. Zhilyakovdr 93 05.04.17 15:03 Сейчас в теме
"Позволяет быстрее ознакомиться со сложными правилами обмена" - в сложных правилах обмена вы этой поделкой ничего хорошего, а самое главное нужного не увидите.
13. Lem0n 162 05.04.17 17:28 Сейчас в теме
(12)Так поведай миру, что хорошее и что плохое, нужное и ненужное.
14. RailMen 777 04.11.17 13:14 Сейчас в теме
Интересная обработка, заслуживающая как минимум лайка, но я всегда придерживаюсь идеи оптимально использовать только типовые инструменты, если это конечно возможно. За последние пол года штук 12 не самых тривиальных правил обмена написал. Про один из них написал статью и опубликовал на ИСе.https://infostart.ru/public/695916/ И во всех случаях типового инструментария мне хватало.
19. sisdrou 22 02.05.18 17:29 Сейчас в теме
Можно добавлять реквизиты cf без обновления правил ?
23. Lem0n 162 02.05.18 20:41 Сейчас в теме
(19)
Аж два варианта:
1.
Обработка загрузки метаданных конфигурации по СОМ(необязательно) //infostart.ru/public/76688/

2. Стандартный см. файл
26. sisdrou 22 03.05.18 15:01 Сейчас в теме
(23)
2. Стандартный см. файл

Зачем мне ссылка на другую обработку. Я про твою публикацию спрашиваю.

Без обновления правил. По ходу нельзя (
27. Lem0n 162 03.05.18 15:29 Сейчас в теме
(26)
1. Указанную обработку загрузки метаданных я использую в своем инструменте
2. Это обновление метаданных штатными средствами
20. DAnry 6 02.05.18 19:03 Сейчас в теме
При запуске выдает ошибку:
{ВнешняяОбработка.РПО2М.Форма.ФормаПОД.Форма(4639,61)}:
Процедура или функция с указаным именем не определена (СтрНайти)
ИнициализацияВПриемнике = ИмяКолонки = "ТипПриемника" ИЛИ <<?>>СтрНайти(ИмяКолонки, "АП") = 1;
22. Lem0n 162 02.05.18 20:35 Сейчас в теме
(20)
8.3. (где разрешили в расширении общие модули)

СтрНайти реализована в версии 8.3.6.1977.
Либо обнови платформу, либо замени на Найти
24. DAnry 6 03.05.18 00:44 Сейчас в теме
(22)
С платформой у меня все норм. 8.3.8.2054.
Разобрался сам. Режим совместимости нужно менять, не ниже 8.3.6
Но полезли другие ошибки: типа не найдено БиблиотекаКартинок.РПО2_ЗначокНастройкаПараметров и т.д. и т.п.
Мое мнение: автор "халявщик", обработка сырая, требует доработки "напильником"
25. Lem0n 162 03.05.18 09:11 Сейчас в теме
(24)
Ты системные требования читаешь?

КД 2.1.8.2 + 8.3. (где разрешили в расширении общие модули)
Инструменты Разработчика //infostart.ru/public/15126/ (необязательно, но придется немного выковыривать связанное с этой конфигурацией)
Обработка загрузки метаданных конфигурации по СОМ(необязательно) //infostart.ru/public/76688/
Расширение РПО2 + модификация КД2 для клиент-серверного варианта(для файлового расширения достаточно). Расширение требуется для оповещения формы РПО об изменениях объектов.

Необходимая картинка в расширении
28. psamt1k 03.05.18 16:47 Сейчас в теме
Обязательно опробуем, как наберем нужное количество мани.

P.S: Небольшая орфографическая ошибка - в блоке "Скачать файлы" - раСширение (буква С пропущена)
29. KliMich 30.05.18 16:40 Сейчас в теме
Отличный редактор!
Опробовал в файловом варианте. Здорово.
Но столкнулся с ошибкой в данном редакторе
1. Перехожу в справочник Конвертации, нажимаю "Скопировать конвертацию"
2. Выдает ошибку "Ошибка при установке значения атрибута контекста (Алгоритм)
{МодульОбычногоПриложения (326)}: Ошибка при вызове метода контекста (Записать)
НовыйЗлемент.Записать();
по причине:
Ошибка при выполнении обработчика - `ПередЗаписью`
по причине:
{РПО2_Общиймодуль.РПО2_СобытияМодуляОбъекта.Модуль(65)}: Ошибка при установке значения атрибута контекста (Алгоритм)
по причине:
Реквизит недоступен для группы

Подскажите, плиз, что я сделал не правильно.
Режим совместимости стоит не использовать (1с 8.3.12.1412)
Может я наставил лишние галочки при объединении с ИнструменыРазработчика (вроде действовал по инструкции на сайте http://devtool1c.ucoz.ru)

А можно ли выложить конфигурацию (.cf ил .dt) КД с внедренной подсистемой "Инструменты разработчика"
Пусть стоит больше 3 стартмани - скачаю.

И еще интересно. А планируется ли дальнейшее совершенствование вашей разработки? Хотелось бы продолжения...
30. Lem0n 162 04.06.18 09:27 Сейчас в теме
(29)
Это мой косяк в расширении.
Выкладывая продукты 1С и материалы из других публикаций, чувствую, нарушу несколько правил форума:).
Я каждый год расширяю возможности редактора, автоматизируя свою работу, Какие идеи по расширению функциональности есть у тебя?
31. KliMich 05.06.18 19:02 Сейчас в теме
(30)
Обновление установил. Команда "Скопировать конвертацию" проходит без ошибок. Спасибо!
Начну теперь плотно работать с РПО-2М.
Но пока идей по расширению функционала нет, т.к. еще слабо разобрался c возможностями редактора.
33. nagaitseff 22 25.03.19 07:35 Сейчас в теме
Что-то не понял про установку? Можете пояснить по шагам? Как установить?!
36. Lem0n 162 25.03.19 09:33 Сейчас в теме
Что пояснить? Что не понятно в системных требованиях?
34. nagaitseff 22 25.03.19 09:22 Сейчас в теме
{Обработка.РПО2М.Форма.ФормаПОД.Форма(503)}: Поле объекта не обнаружено (мПараметрКлючИлиОбъект)
ФормаОбработки.мПараметрКлючИлиОбъект = ОбъектБД;
35. Lem0n 162 25.03.19 09:29 Сейчас в теме
(34) Необходимо установить ИР согласно пункту 2 системных требований
37. nagaitseff 22 25.03.19 11:25 Сейчас в теме
(35) Спасибо, разобрался, вот только ошибка при нажатии на кнопку Редактор ПКС
{Обработка.РПО2М.Форма.ФормаПОД.Форма(503)}: Поле объекта не обнаружено (мПараметрКлючИлиОбъект)
ФормаОбработки.мПараметрКлючИлиОбъект = ОбъектБД;
38. Lem0n 162 25.03.19 12:08 Сейчас в теме
39. nagaitseff 22 25.03.19 12:18 Сейчас в теме
40. Lem0n 162 25.03.19 13:41 Сейчас в теме
(39) В ИР поменялось имя реквизита. Букву "м" убери:

ФормаОбработки.ПараметрКлючИлиОбъект = ОбъектБД;
ФормаОбработки.ПараметрПрочитатьОбъект = Истина;
42. nagaitseff 22 26.03.19 05:14 Сейчас в теме
43. German_Tagil 6 28.03.19 10:06 Сейчас в теме
скачал Редактор правил обмена КД2.epf
Не запустился - не пойму что надо сделать

1С:Предприятие 8.3 (8.3.13.1513)
Конвертация данных, редакция 2.1 (2.1.8.2)

Copyright © ЗАО "1C", 2005 - 2013. Все права защищены
(http://www.1c.ru)
{ВнешняяОбработка.РПО2М.Форма.ФормаПОД.Форма(54,30)}: Переменная не определена (РПО2_ОбщегоНазначенияПовтИсп)
ПараметрыПроверки.Добавить(<<?>>РПО2_ОбщегоНазначенияПовтИсп.ВерсияРасширения());
{ВнешняяОбработка.РПО2М.Форма.ФормаПОД.Форма(60,44)}: Переменная не определена (РПО2_ОбщегоНазначенияПовтИсп)
Строка(ЭтотОбъект.Версия()) + <<?>>РПО2_ОбщегоНазначенияПовтИсп.ВерсияРасширения(), "Проверка обновления РПО-2М");
{ВнешняяОбработка.РПО2М.Форма.ФормаПОД.Форма(398,42)}: Переменная не определена (ирОбщий)
ФормаОбработки.УстановитьОбластьПоиска(<<?>>ирОбщий.ПолучитьИмяТаблицыИзМетаданныхЛкс("Справочник.ПравилаКонвертацииСвойств"));
{ВнешняяОбработка.РПО2М.Форма.ФормаПОД.Форма(426,42)}: Переменная не определена (ирОбщий)
ФормаОбработки.УстановитьОбластьПоиска(<<?>>ирОбщий.ПолучитьИмяТаблицыИзМетаданныхЛкс("Справочник.ПравилаКонвертацииОбъектов"));
{ВнешняяОбработка.РПО2М.Форма.ФормаПОД.Форма(452,42)}: Переменная не определена (ирОбщий)
ФормаОбработки.УстановитьОбластьПоиска(<<?>>ирОбщий.ПолучитьИмяТаблицыИзМетаданныхЛкс(ПолноеИмя));
{ВнешняяОбработка.РПО2М.Форма.ФормаПОД.Форма(540,17)}: Переменная не определена (ирОбщий)
Менеджер = <<?>>ирОбщий.ПолучитьМенеджерЛкс(МетаданныеОбъекта);
{ВнешняяОбработка.РПО2М.Форма.ФормаПОД.Форма(4752,61)}: Процедура или функция с указанным именем не определена (СтрНайти)
ИнициализацияВПриемнике = ИмяКолонки = "ТипПриемника" ИЛИ <<?>>СтрНайти(ИмяКолонки, "АП") = 1;
44. Lem0n 162 28.03.19 12:03 Сейчас в теме
(43) Не подключено расширение согласно пункту 4 системных требований и не интегрирована ИР согласно пункту 2
Оставьте свое сообщение